LiquidPlanner Website & Support pages unavailable
Incident Report for LiquidPlanner
Resolved
This incident has been resolved.
Posted May 12, 2023 - 17:05 PDT
Investigating
Our website and support hub may not be accessible for some users. We are currently investigating the issue.
Access your workspace here:
Classic LiquidPlanner: https://app.liquidplanner.com/login.
New LiquidPlanner: https://next.liquidplanner.com/login

Until self help is up and running again, feel free to contact support@liquidplanner.com.
For help purchasing, please contact productadvisors@liquidplanner.com.

We are investigating and will post updates here when we have more information to share. This issue does not affect workspace performance or access; our apps are working as expected.
Posted May 12, 2023 - 16:25 PDT