Resolved
We're no longer seeing errors in the affected region. We'll continue to monitor, but no further issues are expected.
Identified
There's an ongoing incident in the AWS region our services are hosted, which causes errors with certain features of Portfolio Manager, including emails, project scheduling, and image uploads. We'll provide further information as we learn more.