The release has been completed and new features are deployed. See the Release Notes to find out what's new.
Posted Sep 08, 2021 - 11:30 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 08, 2021 - 11:01 PDT
Scheduled
The New LiquidPlanner (next.liquidplanner.com) application will receive a software update at 11am Pacific time on Tuesday, September 28, 2021 to release new features. The application will be available during the update. No downtime is expected.
Posted Sep 08, 2021 - 11:00 PDT
This scheduled maintenance affected: Portfolio Manager NEW (https://next.liquidplanner.com) (The latest from LiquidPlanner at https://next.liquidplanner.com/).