The scheduled maintenance has been completed. See the Release Notes to find out what's new.
Posted Aug 30, 2023 - 17:30 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 30, 2023 - 17:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 30, 2023 - 08:51 PDT
Scheduled
LiquidPlanner New (next.liquidplanner.com) will have a software update at 5:00pm Pacific on Wednesday, August 30 to release new features. No downtime is expected, but there may be some latency while the updates are in progress.
Posted Aug 30, 2023 - 08:46 PDT
This scheduled maintenance affected: Portfolio Manager NEW (https://next.liquidplanner.com) (The latest from LiquidPlanner at https://next.liquidplanner.com/).